We will configure a eBGP peering between two routers by referring to the topology below.

 

Router 1 configuration is as following:

First we set the IP on the interface that will be connected with Router 2.

interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.252

Next we set the IP on the interface that PC 1 will be connected to.

interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.0

Then we configure eBGP by adding the neigbour and the network we want to advertise.

router bgp 100
neighbor 10.1.1.2 remote-as 200

network 172.16.1.0 mask 255.255.255.0

Router 2 configuration is as following:

First we set the IP on the interface that will be connected with Router 1.

interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.252

Next we set the IP on the interface that PC 2 will be connected to.

interface FastEthernet0/1
ip address 172.16.2.1 255.255.255.0

Then we configure eBGP by adding the neigbour and the network we want to advertise.

router bgp 200
neighbor 10.1.1.1 remote-as 100

network 172.16.2.0 mask 255.255.255.0

We verify that BGP is setup correctly and that routes has been advertised by using the following commands on each router:

show ip bgp
show ip bgp summary
show ip route

First ping returns as timeout because PC 2 sends an ARP request.

This shows that our eBGP is configured correctly and that computers now can communicate with each others.